januari, 2016

now browsing by month

 

Restauratie Fire! Aflevering: Playfield teardown.

Gewoon omdat ik zin heb om wat foto’s te plaatsen bij deze de teardown van mijn speelveld

IMG_0154 IMG_0088 IMG_0144 IMG_0095 IMG_0097 IMG_0139

Reparatie blog deel 3A: Ed’s hardbody MPU

Na mijn laatste repair van Ed’s MPU was e.e.a. helaas nog niet in orde. De nieuwe eproms hebben nog steeds geen positief effect en het bordje lag weer terug op mijn werkbank. Ed had reeds een nieuwe CPU gemonteerd, maar nog steeds niets. Normaliter knippert de led een aantal maal maar deze bleef zo dood als een pier. Dus, Leon’s testrom er in en spanning er op. Geen knipper van de led. Na wat rondprikken met mijn probe kwam ik er achter dat het R/W signaal volledig gaar was. Dus: even alles losgooien van dit R/W en gaan deduceren. (Deduceren kun je leren mensen!)

Bally6803-U5

 

Er bleef dus enkel en alleen U5 over die R/W gebruikt als direction. Vervangen van U5 loste het R/W probleem op, maar nog steeds geen knipperende led. Na wat heen en weer proben zag ik dat pin 10 van de CPU volledig dood was. Op zich geen probleem omdat deze enkel en alleen de LED aanstuurt. Dus bordje terug naar Ed om te testen. (Ik heb zelf geen Bally flipper dus dat wordt voor mij erg lastig).

Helaas was dit dus niet de oplossing. Dus binnen een week had ik het bordje weer retour. Een nieuwe (wederom (?) ) CPU lost dit probleem gelukkig op. Met de testrom knippert de led vrolijk op de maat mee en ook de RAM test wordt netjes doorlopen. Tijd voor de programma roms. En nu moet ik even iets uitleggen. Een Bally bordje heeft een extra voeding nodig anders start deze niet op. Er moet op stekker J1 op pin 2,3 en 4 2 maal 12 volt wisselspanning aangeboden worden, dus heb ik voor een whopping 7 euro een kleine trafo gekocht en deze aan pinnen 2,3 en 4 gehangen. Helaas nog geen enkele beweging in het bordje te krijgen.

Gelukkig heb ik van een andere klant een ander Bally bordje liggen met dezelfde CPU, dus hier maar even wat voeding op gezet en deze begon gezellig te knipperen. Conclusie: voeding goed.

Zie onderstaand schema:

Bally6803-U12

Als ik dan meet op beide bordjes op pinnen 6, 8 en 9 van U12 zie ik het volgende:

6803foutpin6u126803goedpin9u12

Het linkse screenshot is van het foute bordje, het rechtse van het goede. Pin 6 van U12 wordt aan een PIA gevoed om het bordje te laten draaien.

6803foutpin8u12 6803goedpin8u12

Pin 8 van U12. In het linker screenshot zie je dus van de nul ongeveer op de helft ligt van de range. Het rechter screenshot geeft het juiste signaal weer. Omdat er geen duidelijke nul is is ook de output op pin 6 te verklaren.

6803foutpin9u12 6803goedpin6u12

Sja en zo ziet het signaal op ping 9 van U12 uit. Hiervoor geldt hetzelfde als voor pin 8. Het signaal is onwerkbaar.

Conclusie: U12 defect, deze had ik helaas niet op voorraad dus deze zal z.s.m. vervangen worden.

** EDIT ** U12 vervangen en het bordje werkt weer. Mooi, next customer please…

Reparatie Blog Deel 5: Angelo’s X-Files

Okee dan, ik had al geen hoge pet op van Habré BV in Eindhoven, zij kopen kasten op vanuit de exploitatie, vegen er een keer met een doekje langs, doen her en der wat reparaties om de kasten weer aan de gang te krijgen en verkopen de rotzooi dan weer voor veel te veel geld. Gisteren was ik bij een klant die een X-Files had aangekocht. Ik ga niet in detail treden, maar laat me zeggen dat ik niet voor de laatste keer bij die X-Files heb gestaan. Gelukkig hebben we gisteren de kast kunnen voorzien van leds en heb ik wat rubbers kunnen vervangen. Het probleem is dat de kast om de haverklap reset. Na wat onderzoek besloten om de stekkers te vervangen om te kijken of dit het issue oplost, +5 volt is prima namelijk. Maar dat is voor de volgende keer.